Download details
VibrateGameDeviceDriver4.0 32bit VibrateGameDeviceDriver4.0 32bit

 

This driver is VibrateGameDeviceDriver 4.0 version for download. This device driver is for use to support Windows 98/ME/2000/XP/Vista/W7/W8 OS. 。

NOTE. you must uninstall any old version Rockfire driver befor install this new version. And you must upgrade DirectX to 8.1 or high version in Windows 98se and Windows 2000 sysytem.

Upgrade date: 2013/06/30

 

Description of Change:

1. Support Windows 8 and windows 8 preview system.

2. fix Force Feedback wheel.

.

New Products

Rockfire Other